summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafał Kozdrój2018-09-25 17:04:21 +0200
committerRafał Kozdrój2018-09-25 17:04:21 +0200
commit0b86cd9008dcf43c307ab56599f76af87902cfd7 (patch)
tree1fa40cc1567608e4271dbd56254eb1a53454782d /PKGBUILD
parent3313fed21dc3266ff5f3120113178fad5c472dfe (diff)
downloadaur-0b86cd9008dcf43c307ab56599f76af87902cfd7.tar.gz
Update to 3.7.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 23 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf5f91f9d655..0f9d7c6ff6b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
-# Maintainer: kikadf <kikadf.01@gmail.com>
+# Maintainer: Rafał Kozdrój <kozeid2@gmail.com>
+# Contributor: kikadf <kikadf.01@gmail.com>
# Contributor: Daniel Henry <d at hackr dot pl>
# Contributor: Miguel Revilla <yo at miguelrevilla dot com>
# Contributor: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=megasync
-_extname=Win
-pkgver=3.6.7.0
-_sdkver=3.4.0
+_extname=Linux
+pkgver=3.7.1.0
pkgrel=1
pkgdesc="Sync your files to your Mega account. Official app"
arch=('i686' 'x86_64')
-url="https://github.com/meganz/megasync"
+url="https://github.com/meganz/MEGAsync"
license=('custom:MEGA LIMITED CODE REVIEW LICENCE')
depends=('c-ares' 'crypto++' 'libsodium' 'hicolor-icon-theme' 'libuv' 'qt5-svg' 'libmediainfo')
-makedepends=('qt5-tools' 'swig' 'doxygen')
+makedepends=('qt5-tools' 'swig' 'doxygen' 'lsb-release' 'git')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
-source=("https://github.com/meganz/MEGAsync/archive/v${pkgver}_${_extname}.tar.gz"
- "https://github.com/meganz/sdk/archive/v${_sdkver}.tar.gz")
-sha256sums=('7c896e97cc5de168ee75ce6b99f72e33c90dfe31da62ce00d9f4f5ae9f9a96ee'
- '0a13576ac3efb741dd67c43698a99ff1ff721cc806f28908cc0bdba808d4988b')
+source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_${_extname}"
+ "git+https://github.com/meganz/sdk.git")
+sha256sums=('SKIP'
+ 'SKIP')
prepare(){
- rm -rf MEGAsync-${pkgver}_${_extname}/src/MEGASync/mega
- mv sdk-${_sdkver} MEGAsync-${pkgver}_${_extname}/src/MEGASync/mega
+ cd "MEGAsync"
+ git submodule init
+ git config submodule.src/MEGASync/mega.url $srcdir/sdk
+ git submodule update
}
build(){
- cd "MEGAsync-${pkgver}_${_extname}/src/MEGASync/mega"
+ cd "MEGAsync/src/MEGASync/mega"
./autogen.sh
./configure \
--prefix=/usr \
@@ -36,7 +38,6 @@ build(){
--disable-php \
--disable-python \
--enable-chat \
- --enable-gcc-hardening \
--with-cares \
--with-cryptopp \
--with-curl \
@@ -45,28 +46,22 @@ build(){
--with-zlib \
--without-freeimage \
--without-termcap \
- --without-ffmpeg
+ --without-ffmpeg
- cd "${srcdir}/MEGAsync-${pkgver}_${_extname}/src"
+ cd "../.."
qmake-qt5 CONFIG+="release" MEGA.pro
lrelease-qt5 MEGASync/MEGASync.pro
make
}
package (){
- cd "MEGAsync-${pkgver}_${_extname}"
- install -Dm 644 LICENCE.md "${pkgdir}/usr/share/licenses/megasync/LICENCE.md"
+ cd "MEGAsync"
+ install -Dm 644 LICENCE.md "${pkgdir}/usr/share/licenses/megasync/LICENCE"
install -Dm 644 installer/terms.txt "${pkgdir}/usr/share/licenses/megasync/terms.txt"
- cd src/MEGASync
- install -Dm 755 megasync "${pkgdir}/usr/bin/megasync"
-
- cd platform/linux/data
- install -Dm 644 megasync.desktop "${pkgdir}/usr/share/applications/megasync.desktop"
+ cd "src"
+ make INSTALL_ROOT="${pkgdir}" install
- cd icons/hicolor
- for size in 16x16 32x32 48x48 128x128 256x256
- do
- install -Dm 644 "${size}/apps/mega.png" "${pkgdir}/usr/share/icons/hicolor/${size}/apps/mega.png"
- done
+ cd "MEGASync"
+ install -Dm 755 megasync "${pkgdir}/usr/bin/megasync"
}