summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHexchain Tong2017-02-13 21:57:21 +0800
committerHexchain Tong2017-02-13 21:57:21 +0800
commitb0a4ad7c8672529b1b98795f88a800e7eeb2da33 (patch)
tree3b63a32944c33d51ee9784066a98a0abe603075e /PKGBUILD
parentc601aaadb57560514407913f3f8da701a7c2e4d9 (diff)
downloadaur-b0a4ad7c8672529b1b98795f88a800e7eeb2da33.tar.gz
upgpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bbaa0563053..f06083c145d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
# Maintainer: Hexchain Tong <i at hexchain dot org>
pkgname=megasync
-pkgver=2.9.10
-_pkgver=${pkgver//./_}
+pkgver=3.0.1.0
pkgrel=1
pkgdesc="Sync your files to your Mega account. Official app"
arch=('i686' 'x86_64')
url="https://github.com/meganz/megasync"
license=('custom:MEGA LIMITED CODE REVIEW LICENCE')
depends=('curl' 'c-ares' 'crypto++' 'libsodium' 'hicolor-icon-theme' 'qt5-base' 'libuv')
-makedepends=('git' 'qt5-tools')
+makedepends=('git' 'qt5-tools' 'swig' 'doxygen')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
-source=("git+https://github.com/meganz/MEGAsync.git#commit=2e03defad7e732afe5ffd6977eeb10558f25457b")
+source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_Linux")
md5sums=('SKIP')
prepare(){
@@ -23,20 +22,21 @@ build(){
cd "$srcdir/MEGAsync/src/MEGASync/mega"
./autogen.sh
./configure \
+ --prefix=/usr \
+ --disable-examples \
+ --disable-java \
+ --disable-php \
+ --disable-python \
+ --enable-chat \
--enable-gcc-hardening \
- --disable-silent-rules \
- --disable-megaapi \
+ --with-cares \
--with-cryptopp \
+ --with-curl \
--with-sodium \
- --with-zlib \
--with-sqlite \
- --with-cares \
- --with-curl \
+ --with-zlib \
--without-freeimage \
- --without-readline \
- --without-termcap \
- --disable-examples \
- --prefix=/usr
+ --without-termcap
cd "$srcdir/MEGAsync/src"
qmake-qt5 CONFIG+="release" MEGA.pro