summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErin Allison2021-12-15 10:02:55 -0600
committerErin Allison2021-12-15 10:02:55 -0600
commitf49017fbaaf2bbe5b4f50073381788c5e8d82400 (patch)
treedec1482092118b8a7204beccd1f6f26a7b0e0cc1 /PKGBUILD
downloadaur-f49017fbaaf2bbe5b4f50073381788c5e8d82400.tar.gz
Initial upload: melvor-mod-manager 0.3.8-1
Signed-off-by: Erin Allison <erin@eallison.us>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d6324dad884
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Erin Allison <erin@eallison.us>
+
+pkgname=melvor-mod-manager
+pkgver=0.3.8
+pkgrel=1
+pkgdesc='Melvor Mod Manager (M3) allows you to quickly add userscripts and browser extensions as mods to the Steam edition of Melvor Idle.'
+arch=('x86_64')
+license=('MIT')
+url="https://github.com/CherryMace/${pkgname}"
+makedepends=('npm' 'nodejs')
+source=(
+ "${pkgname}.desktop"
+ "${pkgname}.png"
+ "git+https://github.com/CherryMace/${pkgname}#tag=v${pkgver}")
+sha256sums=(
+ '5384e70639166be6834632e66b0f45dddb1421cb1ec25be4b0706a482f047c75'
+ '793cbb7b7f09e82d04fffe6fd23a4089d712d8d5aec2be71b183e9c1a4e18310'
+ 'SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ npm install
+ npm run electron:build
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/lib"
+ cp -r "${srcdir}/${pkgname}/dist_electron/linux-unpacked/" "${pkgdir}/usr/lib/${pkgname}"
+
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -sf "../lib/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/96x96/apps/${pkgname}.png"
+}