summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRipose2023-08-08 22:54:16 -0700
committerRipose2023-08-08 22:54:16 -0700
commit8dd875dab59b505508ce1099e2fd8911782ad04a (patch)
tree3edb8ae4d6ad3154ba2bdab68b765234443edfb8 /PKGBUILD
parentf0a59a47ea297331d49e3b3a4c7e621713980dbd (diff)
downloadaur-8dd875dab59b505508ce1099e2fd8911782ad04a.tar.gz
fix libzip build failure due to deprecated function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 366a11fa8e11..cb9d3e204e18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,9 @@ prepare() {
build() {
cd ${srcdir}/build
+ cmake -E env \
+ CFLAGS="-Wno-error=deprecated-declarations" \
+ CXXFLAGS="-Wno-error=deprecated-declarations" \
cmake -DCMAKE_INSTALL_PREFIX:PATH=${pkgdir}/usr \
-DRELEASE_BUILD=ON \
-DCMAKE_BUILD_TYPE=Release \