summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo2020-05-01 14:44:40 +0200
committerMatteo2020-05-01 14:44:40 +0200
commit7144df0d4df4e6c46a995335fa130c0e1f945ebd (patch)
tree05a31c270a8404384ceca0063b25aa50939f8d06 /PKGBUILD
downloadaur-7144df0d4df4e6c46a995335fa130c0e1f945ebd.tar.gz
Create memethesis-cli
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd8c77f94fb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Matteo Salonia <saloniamatteo@protonmail.com>
+
+pkgname=memethesis-cli
+pkgver=3.2.1
+pkgrel=1
+pkgdesc="Create memes from the terminal"
+arch=('any')
+url="https://github.com/fakefred/memethesis-cli"
+license=('GPL3')
+depends=('python>=3' 'imagemagick')
+source=("https://github.com/fakefred/memethesis-cli/archive/3.2.1.tar.gz")
+sha256sums=("3c0b1727bdc8e7c39885cdbfcdf6bc1daeae84b8be4780c756f053e42a37e31c")
+
+package() {
+ # go into memethesis-cli-3.2.1-1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # install memethesis-cli; binary is in /usr/bin/memethesis
+ python3 setup.py install --root="$pkgdir"
+}