summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo2020-05-01 15:54:09 +0200
committerMatteo2020-05-01 15:54:09 +0200
commite28db50a9eb5c04ba1e1c79ac3f7edb5b058e62b (patch)
tree11cb5e98ff1c18139e6e34a5247e8492be12734f /PKGBUILD
parent859ccd5aa5638b6c18166e8149e6acc23f6a0df1 (diff)
downloadaur-e28db50a9eb5c04ba1e1c79ac3f7edb5b058e62b.tar.gz
Add needed python dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 485c59e4f2c4..9bf0e28bd7f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Create memes from the terminal"
arch=('any')
url="https://github.com/fakefred/memethesis-cli"
license=('GPL3')
-depends=('python>=3' 'imagemagick')
+depends=('python>=3' 'python-pip' 'imagemagick')
makedepends=('git')
# 3.2.1 is the version that can be downloaded in the releases
# We will be using 3.3.0 but we'll have to clone the entire repo
@@ -16,6 +16,11 @@ makedepends=('git')
source=("git+https://github.com/fakefred/${pkgname}.git")
sha256sums=("SKIP")
+prepare() {
+ # install python dependencies
+ pip3 install PyYAML Pillow PyInquirer colored ascim
+}
+
package() {
# go into memethesis-cli
cd "${srcdir}/${pkgname}"