summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoramoka2020-12-13 00:00:52 -0500
committeramoka2020-12-13 00:00:52 -0500
commitc17d8a3841b45730dedf38a12fbf61952cdbe789 (patch)
tree6629eeef0609bc7c0272aa1111d6485378f82a7a /PKGBUILD
downloadaur-c17d8a3841b45730dedf38a12fbf61952cdbe789.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0228b3a5e496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
+
+pkgname=memstrack
+pkgver=0.1.12
+pkgrel=1
+pkgdesc="A memory allocation trace, like a hot spot analyzer for memory allocation"
+arch=('any')
+url="https://github.com/ryncsn/memstrack"
+license=('GPL3')
+makedepends=('gcc' 'ncurses')
+source=("https://github.com/ryncsn/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('2e0150b41be36d99fb9e3f25f75da1755a598b408c517e25ffd8c3e727b32eb9')
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dt "$pkgdir/usr/bin" -m755 memstrack
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE
+}