summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoramoka2020-12-19 22:33:06 -0500
committeramoka2020-12-19 22:33:06 -0500
commit76b0c011e63f467c8fea6f30e7db64556545a166 (patch)
tree0ba59ed8853728da3bb3dead10799168dd1b722e /PKGBUILD
downloadaur-76b0c011e63f467c8fea6f30e7db64556545a166.tar.gz
Initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8479fb317d1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
+
+pkgname=memstrack-git
+pkgver=0.1.12.r8.ga93d5ad
+pkgrel=1
+pkgdesc="A memory allocation trace, like a hot spot analyzer for memory allocation (from git)"
+arch=('any')
+url="https://github.com/ryncsn/memstrack"
+license=('GPL3')
+makedepends=('gcc' 'git' 'ncurses')
+provides=('memstrack')
+conflicts=('memstrack')
+source=("git+https://github.com/ryncsn/memstrack.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd memstrack
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd memstrack
+ make
+}
+
+package() {
+ cd memstrack
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+}