summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:48:53 -0700
committerAnatol Pomozov2015-06-17 08:48:53 -0700
commitbeff402edfacd4a0c1991dc85d8568414164c10b (patch)
tree93d40215211420a9bd24500897334fd81c4029bd /PKGBUILD
downloadaur-beff402edfacd4a0c1991dc85d8568414164c10b.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56977e37f93b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=menuconfig-git
+pkgver=r17.0a95e19
+pkgrel=1
+pkgdesc='Standalone version of the mconf tool from the linux kernel'
+url='https://github.com/TheGeorge/menuconfig'
+arch=(i686 x86_64)
+license=(GPL2)
+depends=(ncurses)
+makedepends=(git cmake)
+source=(git://github.com/TheGeorge/menuconfig.git)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd menuconfig
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd menuconfig
+ sed -e 's|ncursesw/curses.h|curses.h|' -i lxdialog/dialog.h
+}
+
+build() {
+ cd menuconfig
+ cmake .
+ make
+}
+
+package() {
+ cd menuconfig
+ install -m755 -d "$pkgdir/usr/bin"
+ install -m755 -t "$pkgdir/usr/bin" conf mconf
+}