summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfenuks2017-07-24 20:58:21 +0200
committerfenuks2017-07-24 20:58:21 +0200
commit81b3453ba49cd48830726463c8049ffcd62e1e23 (patch)
treee73a04b485b3ace9ef1c7153aae02d99db326c06 /PKGBUILD
parentf011ba382d24d299852e8c96b420f31a8fc2d795 (diff)
downloadaur-81b3453ba49cd48830726463c8049ffcd62e1e23.tar.gz
Update to 2.5.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec2a4f240f6c..c773f2693b00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=merlin
-pkgver=2.2
+pkgver=2.5.0
pkgrel=1
pkgdesc="Context sensitive completion for OCaml in Vim and Emacs (ocamlmerlin binary only)"
arch=('i686' 'x86_64')
depends=('ocaml' 'ocaml-biniou' 'ocaml-findlib' 'ocaml-yojson' 'python2')
makedepends=('make')
-url="https://github.com/the-lambda-church/merlin"
+url="https://github.com/ocaml/merlin"
license=('MIT')
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/the-lambda-church/$pkgname/tar.gz/v$pkgver)
-sha256sums=('18278c95f9e3c32855a15fc5e14ac349a34001b6d3ab8833bdacaa0a6806562d')
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/ocaml/$pkgname/tar.gz/v$pkgver)
+sha256sums=('4bf4f8b7b3a3852605a7bf8cf576dea569e368cb6642b2d68f435b6d9de55336')
options=('!strip')
provides=('merlin' 'ocaml-merlin')
conflicts=('ocaml-merlin' 'vim-ocaml-merlin-git')
@@ -18,22 +18,22 @@ conflicts=('ocaml-merlin' 'vim-ocaml-merlin-git')
build() {
cd "$srcdir/$pkgname-$pkgver"
- msg 'Building...'
- ./configure
+ ./configure \
+ --prefix "/usr" \
+ --sharedir "/usr/share" \
+ --vimdir "/usr/share/vim/vimfiles" \
+ --enable-compiled-emacs-mode
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- msg 'Installing license...'
- install -Dm 644 LICENSE_MIT.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE_MIT.txt"
+ make install DESTDIR="$pkgdir"
- msg 'Installing documentation...'
- for _doc in `find . -maxdepth 1 -type f -name "*.md" -printf '%f\n'` CHANGELOG; do
+ install -Dm 644 LICENSE_MIT.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+
+ for _doc in $(find . -maxdepth 1 -type f -name "*.md" -printf '%f\n') CHANGELOG; do
install -Dm 644 $_doc "$pkgdir/usr/share/doc/$pkgname/$_doc"
done
-
- msg 'Installing...'
- install -Dm 755 ocamlmerlin "$pkgdir/usr/bin/ocamlmerlin"
}