summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Schoenick2019-09-20 14:04:31 -0700
committerJohn Schoenick2019-09-20 14:04:31 -0700
commit2221ed1f732bccb9e8e64f4af6d8383ba5f12ce3 (patch)
tree9a22753eaec1cf5cca2e33afdcefc8b52f315168 /PKGBUILD
parentc7917d5186a6d7ad645a90bc796a7f32c265483f (diff)
downloadaur-2221ed1f732bccb9e8e64f4af6d8383ba5f12ce3.tar.gz
Update pkgver format to include top commit date
Upstream was rebased and commit depth decreased, which isn't super helpful for a pkgver The YYYYMMDD number here is higher than the old commit depth so there shouldn't be an order issue.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fc1e622993b..cbf9c6ea1cc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
pkgname=mesa-aco-git
pkgdesc="Mesa with the ACO compiler patchset, git version"
-pkgver=19.3.0_devel.115981.f2bed9b344c
-pkgrel=2
+pkgver=19.3.0_devel.20190919.b738bf06917
+pkgrel=3
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio' 'libxrandr'
@@ -100,7 +100,7 @@ depends+=('llvm-libs>=8.0.0' 'llvm-libs<8.1')
pkgver() {
cd mesa-aco
read -r _ver <VERSION
- echo ${_ver/-/_}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ echo ${_ver/-/_}.$(git log -n1 --format="%cd" --date=format:%Y%m%d HEAD).$(git rev-parse --short HEAD)
}
prepare() {