summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Schoenick2019-09-27 14:22:38 -0700
committerJohn Schoenick2019-09-27 15:17:28 -0700
commit54af301e6a92b581b45da070c2e8b69d341e03c9 (patch)
tree5c0d9efd109b5d5c4d7f65e19c9094e36eea498b /PKGBUILD
parent2221ed1f732bccb9e8e64f4af6d8383ba5f12ce3 (diff)
downloadaur-54af301e6a92b581b45da070c2e8b69d341e03c9.tar.gz
Fix .pc file situation by backporting fixes not yet on branch
Brings in from upstream: 893fdda82b70ec4b735e29719597f90d06a1b150 ff97e08ad2ac33e47e72eb4b5f54bd1dc810746c This won't be necessary when ACO rebases again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbf9c6ea1cc0..2d5ddd4746f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
pkgname=mesa-aco-git
pkgdesc="Mesa with the ACO compiler patchset, git version"
-pkgver=19.3.0_devel.20190919.b738bf06917
-pkgrel=3
+pkgver=19.3.0_devel.20190927.d0ed7ce952c
+pkgrel=4
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio' 'libxrandr'
@@ -40,12 +40,14 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa-aco::git+https://github.com/daniel-schuermann/mesa'
'LICENSE'
+ 'glvnd-1.patch'
+ 'glvnd-2.patch'
)
-md5sums=('SKIP'
- '5c65a0fe315dd347e09b1f2826a1df5a'
-)
+
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
+ 'd3a58aaafbdab6e47207327bd519d4af20e39253e04e093be511df3495851d1e405959dfa78930e047846dc735178081e48a41148289e1b70242d877d9a4d129'
+ '70a9f75a6fed2f6e4828f491bc6a3a18daf9dc1bbc9d6d400c39902dddcba0671112c23b1ed5e8ebdc54e344235064e907b166c0dcfe80699a8d71bbb5decdd9'
)
@@ -109,6 +111,10 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+ cd "$srcdir"/mesa-aco
+ # Cherry-picks that haven't made it to the ACO branch yet to fix the .pc file situation with glvnd/egl
+ patch -Np1 -i "$srcdir"/glvnd-1.patch
+ patch -Np1 -i "$srcdir"/glvnd-2.patch
}
build () {
@@ -156,10 +162,5 @@ package() {
# indirect rendering
ln -s /usr/lib/libGLX_mesa.so.0 "${pkgdir}"/usr/lib/libGLX_indirect.so.0
- # drop egl.pc -- upstream mesa has dropped this to fix confusion over who should provide it (conclusion: libglvnd),
- # but as of 7/23 the ACO upstream doesn't have that patch. Drop it now so we don't conflict with the libglvnd
- # provider, next ACO rebase should remove this file when they pick up c7831b604063
- rm -f "$pkgdir"/usr/lib/pkgconfig/egl.pc
-
install -Dt "$pkgdir"/usr/share/licenses/$pkgname "$srcdir"/LICENSE
}