summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLW-archlinux2020-02-12 01:06:05 +0100
committerLW-archlinux2020-02-12 01:06:05 +0100
commit5e041ee425ddb2318c6971f00d697eb5f7bb6b4c (patch)
tree4676a198528d99f9333b9de0595fee20138761fd /PKGBUILD
parent9d52ad24971f5cd317a032aed8b7eecaa7d38770 (diff)
downloadaur-5e041ee425ddb2318c6971f00d697eb5f7bb6b4c.tar.gz
added zstd as dependecy, also building with zstd=true
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5529ca8903d7..51aa38e0fc9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,14 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=20.0.0_devel.119653.4d03e531273
+pkgver=20.1.0_devel.120096.286141197da
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio' 'libxrandr'
'ocl-icd' 'libgcrypt' 'wayland' 'wayland-protocols' 'meson' 'ninja')
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
- 'libomxil-bellagio' 'libunwind' 'libglvnd' 'wayland' 'lm_sensors' 'libclc' 'glslang' 'vulkan-icd-loader')
+ 'libomxil-bellagio' 'libunwind' 'libglvnd' 'wayland' 'lm_sensors' 'libclc' 'glslang' 'vulkan-icd-loader' 'zstd')
optdepends=('opengl-man-pages: for the OpenGL API man pages')
provides=(mesa=$pkgver-$pkgrel vulkan-intel=$pkgver-$pkgrel vulkan-radeon=$pkgver-$pkgrel vulkan-mesa-layer=$pkgver-$pkgrel libva-mesa-driver=$pkgver-$pkgrel mesa-vdpau=$pkgver-$pkgrel vulkan-driver opencl- opengl-driver opencl-driver)
conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau')
@@ -125,7 +125,8 @@ build () {
-D gallium-opencl=icd \
-D valgrind=false \
-D vulkan-overlay-layer=true \
- -D tools=[]
+ -D tools=[] \
+ -D zstd=true
meson configure _build
ninja $NINJAFLAGS -C _build