summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2020-03-06 22:56:48 +0100
committerLone_Wolf2020-03-06 22:56:48 +0100
commit9ade7c8055b1a90a215edb6588ab699edc9cf2cd (patch)
tree44d4192f451e08269f71aaa4a7b77870a53a4513 /PKGBUILD
parentb421544cb8ab0553d70de63bd4acfc8827ac8728 (diff)
downloadaur-9ade7c8055b1a90a215edb6588ab699edc9cf2cd.tar.gz
added commands to update translation files (used by DRI configuration tool)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f9333fae415..5807c7343c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=20.1.0_devel.120682.2d32248f49e
+pkgver=20.1.0_devel.120873.70349a2252a
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -126,10 +126,16 @@ build () {
-D valgrind=false \
-D vulkan-overlay-layer=true \
-D tools=[] \
- -D zstd=true
+ -D zstd=true \
meson configure _build
- ninja $NINJAFLAGS -C _build
+
+ # quoted from https://www.mesa3d.org/meson.html
+ # Note: autotools automatically updated translation files (used by the DRI configuration tool) as part of the build process, Meson does not do this.
+ # Instead, you will need do this:
+ ninja $NINJAFLAGS -C _build xmlpool-pot xmlpool-update-po xmlpool-gmo
+ #
+ ninja $NINJAFLAGS -C _build
}
package() {