summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Schoenick2019-10-19 18:09:40 -0700
committerJohn Schoenick2019-10-19 18:09:40 -0700
commita3abfa9366c068ef94872410e184d3d350b41f4d (patch)
treed328ad4d5ba18ca02899c5597f3bbb9bfe47e186 /PKGBUILD
parent74b111718ec18396d5fbd93c92c9d6b88e24ebd9 (diff)
downloadaur-a3abfa9366c068ef94872410e184d3d350b41f4d.tar.gz
Pull in libglvnd headers fix from upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c76c6f85e44..bd61da3354d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
pkgname=mesa-aco-git
pkgdesc="Mesa with the ACO compiler patchset, git version"
-pkgver=19.3.0_devel.20191010.1b2cbc98c39
-pkgrel=6
+pkgver=19.3.0_devel.20191017.fe930ad92ab
+pkgrel=7
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio' 'libxrandr'
@@ -40,10 +40,12 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa-aco::git+https://github.com/daniel-schuermann/mesa'
'LICENSE'
+ 'mesa-headers.patch'
)
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
+ 'f83d52292f9b5144fc2f5b568cfb1d4bdebd37b877d34d9002335d79f66612123001c36a9615ed13f474771002672f2a445a89f3220d16b962e17087b6111644'
)
@@ -107,6 +109,13 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+
+ cd "$srcdir"/mesa-aco
+
+ # Apply this until ACO is rebased and contains it
+ if ! git show b57fa7ca49f7ddb67ac47f392de05af388e73565 &>/dev/null; then
+ patch -Np1 -i "$srcdir"/mesa-headers.patch
+ fi
}
build () {