summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLW-archlinux2019-09-02 14:50:21 +0200
committerLW-archlinux2019-09-02 14:50:21 +0200
commita73bf6fe5a6d8096f3814b2e86e2d1fc42759fe5 (patch)
treeeae1970d2fcd58aebf7d6762a6b562034ebeca67 /PKGBUILD
parent191ca95ed1ebd7a71e3be2aee214a0fa15330c71 (diff)
downloadaur-a73bf6fe5a6d8096f3814b2e86e2d1fc42759fe5.tar.gz
added patch for clang compiler invocation error, unfortunately that gives new errors. disabled building opencl-clover for now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8e859c9afbc..114648f75909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=19.2.0_devel.113971.74470baebbd
+pkgver=19.3.0_devel.114998.966a455bb91
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -25,14 +25,15 @@ conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-laye
url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git://anongit.freedesktop.org/mesa/mesa'
- 'LICENSE'
+ 'LICENSE'
+ 'ArrayRefized-CompilerInvocation-CreateFromArgs.patch'
)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
-)
+ '52394ac3164a6e2f568a10ec09839a25')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
-)
+ '80ff36cc13c884a07f7fe8d5997014094c18a9d47c206afa14cb73dc964c6cffb9e1427939111354ee519c553887fe1dc2bae5a6911cf3d6b7f326a28fa28f31')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -91,6 +92,9 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+
+ cd mesa
+ patch --forward --strip=1 --input="$srcdir"/ArrayRefized-CompilerInvocation-CreateFromArgs.patch
}
build () {
@@ -123,7 +127,7 @@ build () {
-D lmsensors=true \
-D osmesa=gallium \
-D shared-glapi=true \
- -D gallium-opencl=icd \
+ -D gallium-opencl=disabled \
-D valgrind=false \
-D vulkan-overlay-layer=true \
-D tools=[]