summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Schoenick2019-07-23 13:17:26 -0700
committerJohn Schoenick2019-07-23 13:17:26 -0700
commitaa395ca1975a079ce89041770d959e95f6f74f3e (patch)
tree0465e5be30a3b8767aa1812e99e33db45bb8bd92 /PKGBUILD
parentc1ad361e418042a1cd27d7eefd62c5cde9f80665 (diff)
downloadaur-aa395ca1975a079ce89041770d959e95f6f74f3e.tar.gz
Remove egl.pc to avoid conflict, bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e40e5b3519b2..e00863c5bfa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-aco-git
pkgdesc="Mesa with the ACO compiler patchset, git version"
-pkgver=19.2.0_devel.113862.3f3665b8d52
+pkgver=19.2.0_devel.114249.17d9490cef1
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -153,7 +153,12 @@ package() {
DESTDIR="$pkgdir" ninja $NINJAFLAGS -C _build install
# indirect rendering
- ln -s /usr/lib/libGLX_mesa.so.0 ${pkgdir}/usr/lib/libGLX_indirect.so.0
+ ln -s /usr/lib/libGLX_mesa.so.0 "${pkgdir}"/usr/lib/libGLX_indirect.so.0
+
+ # drop egl.pc -- upstream mesa has dropped this to fix confusion over who should provide it (conclusion: libglvnd),
+ # but as of 7/23 the ACO upstream doesn't have that patch. Drop it now so we don't conflict with the libglvnd
+ # provider, next ACO rebase should remove this file when they pick up c7831b604063
+ rm -f "$pkgdir"/usr/lib/pkgconfig/egl.pc
install -Dt "$pkgdir"/usr/share/licenses/$pkgname "$srcdir"/LICENSE
}