summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2020-04-10 22:46:10 +0200
committerLone_Wolf2020-04-10 22:46:10 +0200
commitc18e2a417553ebf2d9c638fb7976981f08046ef5 (patch)
treeb30fddf5e75e46b107e075d56f2e1b93856ab0ae /PKGBUILD
parent6bfd09ff5beadc8342119c5ca81ca41d9a2987f8 (diff)
downloadaur-c18e2a417553ebf2d9c638fb7976981f08046ef5.tar.gz
opencl was failing unless certain depends were installed, added optdepends to clarify.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c7e58092501..a93e983f6144 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=20.1.0_devel.121982.dbdd0149ed5
+pkgver=20.1.0_devel.122181.7aa6720ba4e
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -54,22 +54,26 @@ case $MESA_WHICH_LLVM in
# aur llvm-minimal-git
makedepends+=('llvm-minimal-git')
depends+=('llvm-libs-minimal-git')
+ optdepends+=('llvm-minimal-git: opencl')
;;
2)
# aur llvm-git
# depending on aur-llvm-* to avoid mixup with LH llvm-git
makedepends+=('aur-llvm-git')
depends+=('aur-llvm-libs-git')
+ optdepends+=('llvm-git: opencl')
;;
3)
# mesa-git/llvm-git (lordheavy unofficial repo)
makedepends+=('llvm-git' 'clang-git')
depends+=('llvm-libs-git')
+ optdepends+=('clang-git: opencl' 'compiler-rt: opencl')
;;
4)
# extra/llvm
makedepends+=(llvm=9.0.1 clang=9.0.1)
depends+=(llvm-libs=9.0.1)
+ optdepends+=('clang: opencl' 'compiler-rt: opencl')
;;
*)
esac