summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLW-archlinux2019-09-03 02:58:48 +0200
committerLW-archlinux2019-09-03 02:58:48 +0200
commitc4d7449dff64993303a6c44e986a5bad2de5e285 (patch)
treed87ebaf38bd6ef2a1701d6529a0317082e8b9f1d /PKGBUILD
parenta73bf6fe5a6d8096f3814b2e86e2d1fc42759fe5 (diff)
downloadaur-c4d7449dff64993303a6c44e986a5bad2de5e285.tar.gz
opencl build fail was due to llvm trunk commits that were reverted, opencl support re-enabled
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 114648f75909..d54b515124cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=19.3.0_devel.114998.966a455bb91
+pkgver=19.3.0_devel.115005.538820ff5ff
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -94,7 +94,10 @@ prepare() {
fi
cd mesa
- patch --forward --strip=1 --input="$srcdir"/ArrayRefized-CompilerInvocation-CreateFromArgs.patch
+ if [[ $MESA_WHICH_LLVM < 4 ]]; then
+ # this patch is only needed when building against llvm trunk
+ patch --forward --strip=1 --input="$srcdir"/ArrayRefized-CompilerInvocation-CreateFromArgs.patch
+ fi
}
build () {
@@ -127,7 +130,7 @@ build () {
-D lmsensors=true \
-D osmesa=gallium \
-D shared-glapi=true \
- -D gallium-opencl=disabled \
+ -D gallium-opencl=icd \
-D valgrind=false \
-D vulkan-overlay-layer=true \
-D tools=[]