summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2024-06-10 15:23:14 +0200
committerLone_Wolf2024-06-10 15:31:43 +0200
commit4d414285d34718157fb615036525dfe9128bda9c (patch)
tree2e4652f65c0b016087f7b131e57f1c426d491f20 /PKGBUILD
parent6281ebf67840f8ba53a6ab6ec16aef39a3c230bd (diff)
downloadaur-4d414285d34718157fb615036525dfe9128bda9c.tar.gz
renamed internal rusticl var to _rusticl, also preparations to add rusticl support with llvm-minimal-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4dbcfd405fd..f56da0208b04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -142,11 +142,12 @@ done
# 4 llvm (stable from extra) Default value
#
-rusticl=false
+_rusticl=false
MESA_WHICH_LLVM=${MESA_WHICH_LLVM:-4}
case $MESA_WHICH_LLVM in
1)
# aur llvm-minimal-git
+ _rusticl=true
makedepends+=(
'llvm-minimal-git'
'libclc-minimal-git'
@@ -196,7 +197,7 @@ case $MESA_WHICH_LLVM in
optdepends+=('clang: opencl' 'compiler-rt: opencl')
conflicts+=('opencl-rusticl-mesa')
provides+=('opencl-rusticl-mesa')
- rusticl=true
+ _rusticl=true
;;
*)
esac
@@ -248,7 +249,7 @@ build () {
-D gallium-nine=true
-D gallium-omx=bellagio
-D gallium-opencl=icd
- -D gallium-rusticl=${rusticl}
+ -D gallium-rusticl=${_rusticl}
-D gallium-va=enabled
-D gallium-vdpau=enabled
-D gallium-xa=enabled