summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2020-07-16 13:27:44 +0200
committerLone_Wolf2020-07-16 13:27:44 +0200
commit8aa88df382c1c3339a877e465d8ba9e016b2a7b5 (patch)
tree5a27bf1ddb2f35cb10636112253c2f314cb048fa /PKGBUILD
parenta8e3ec73460001ce6860a73e3dcec58fe6e65218 (diff)
downloadaur-8aa88df382c1c3339a877e465d8ba9e016b2a7b5.tar.gz
switched to b_ndebug=false for now, also corrected permissions for license file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32b1ebd6194c..ae3904013bc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=20.2.0_devel.125631.ab9ecb607b8
-pkgrel=1
+pkgver=20.2.0_devel.126148.97f8ec321b7
+pkgrel=2
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio' 'libxrandr'
@@ -98,7 +98,7 @@ prepare() {
build () {
meson setup mesa _build \
- -D b_ndebug=true \
+ -D b_ndebug=false \
-D b_lto=true \
-D buildtype=plain \
--wrap-mode=nofallback \
@@ -155,5 +155,5 @@ package() {
# indirect rendering
ln -s /usr/lib/libGLX_mesa.so.0 "${pkgdir}/usr/lib/libGLX_indirect.so.0"
- install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE"
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE"
}