summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2021-02-26 22:37:10 -0500
committerVincent Grande2021-02-26 22:37:10 -0500
commitdf0b44ef37c49e317f91321d3871fafb78dd6e44 (patch)
tree961eec2290e1026d92c6e48c733da7ee8e89d48d /PKGBUILD
parent8aa3e4d9fe33d191ec40f3d046d2cc5949e0229d (diff)
downloadaur-df0b44ef37c49e317f91321d3871fafb78dd6e44.tar.gz
add patches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89876123c11d..fa672d29bccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,8 +30,12 @@ conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-laye
url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
- 'LICENSE')
+ 'LICENSE'
+ '8543 clover Fix build with llvm-12.patch'
+ '0001-clover-llvm13-use-FixedVectorType.patch')
sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
# ninja grabs all available cores and leaves almost nothing for other processes.
@@ -94,6 +98,10 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+
+ cd mesa
+ patch --forward --strip=1 --input="${srcdir}/8543 clover: Fix build with llvm-12.patch"
+ patch --forward --strip=1 --input="${srcdir}/0001-clover-llvm13-use-FixedVectorType.patch"
}
build () {