summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2023-09-13 15:06:23 +0200
committerLone_Wolf2023-09-13 15:06:23 +0200
commit008523999aaedab9df81ef944e1cf776433d576c (patch)
treeba4f9cff107403e49553c11991cf7c13106074f8 /PKGBUILD
parent908f5dec1e59c49a3fbe8fe787a66408a632f65b (diff)
downloadaur-008523999aaedab9df81ef944e1cf776433d576c.tar.gz
adjusted pkgver to work with input files without newline chars
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 150266cf85e0..08abeba53431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=mesa-minimal-git
pkgname=(mesa-minimal-git opencl-rusticl-mesa-minimal-git)
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=23.3.0_devel.177601.b5c2e91e4a6
+pkgver=23.3.0_devel.177776.210f1e14d5a
pkgrel=1
arch=('x86_64')
makedepends=(git meson ninja libglvnd python-mako xorgproto libxml2 libx11 libva elfutils libxrandr
@@ -41,7 +41,8 @@ options=(!emptydirs)
pkgver() {
cd mesa
- read -r _ver <VERSION
+ local _ver
+ read -r _ver < VERSION || [ -n "_ver" ]
echo ${_ver/-/_}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}