summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2021-01-09 15:48:46 +0100
committerLone_Wolf2021-01-09 15:48:46 +0100
commit2ed8d8a963e97d35d268ff6dcdafbadc9ba18dc9 (patch)
tree796745287ceff22ee59159bfca6008e3e69f205a /PKGBUILD
parent58c2e6b26b090e5d81e7467c5a2e9860c1544737 (diff)
downloadaur-2ed8d8a963e97d35d268ff6dcdafbadc9ba18dc9.tar.gz
initial release by me
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD101
1 files changed, 28 insertions, 73 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3cf514bedf7..4acd2c8368bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Maintainer: Vincent Grande <shoober420@gmail.com>
-# Contributor: Lone_Wolf <lone_wolf@klaas-de-kat.nl>
+# Maintainer: Lone_Wolf <lone_wolf@klaas-de-kat.nl>
+# Contributor: Vincent Grande <shoober420@gmail.com>
# Contributor: Armin K. <krejzi at email dot com>
# Contributor: Kristian Klausen <klausenbusk@hotmail.com>
# Contributor: Egon Ashrafinia <e.ashrafinia@gmail.com>
@@ -11,18 +11,21 @@
# Contributor: Diego Jose <diegoxter1006@gmail.com>
pkgname=mesa-minimal-git
-pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.0.0_devel.132039.6df572532dc
-pkgrel=1
+pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
+pkgver=21.0.0_devel.133218.b634d7f3e2b
+pkgrel=2
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libxrandr'
- 'ocl-icd' 'wayland-protocols' 'meson' 'ninja' 'glslang')
+ 'ocl-icd' 'wayland-protocols' 'meson' 'ninja' 'glslang' 'llvm-minimal-git')
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
- 'libomxil-bellagio' 'libglvnd' 'wayland' 'libclc' 'vulkan-icd-loader' 'zstd' 'expat')
-optdepends=('opengl-man-pages: for the OpenGL API man pages')
-provides=('mesa' 'mesa-git' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau' 'vulkan-driver' 'opengl-driver' 'opencl-driver')
-conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau')
+ 'libunwind' 'libglvnd' 'wayland' 'lm_sensors' 'libclc' 'vulkan-icd-loader' 'zstd' 'llvm-libs-minimal-git')
+# In order to keep the package simple and ease troubleshooting only use one llvm implementation
+optdepends=('opengl-man-pages: for the OpenGL API man pages'
+ 'llvm-minimal-git: opencl')
+provides=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'vulkan-swrast' 'vulkan-driver' 'opengl-driver' 'opencl-driver')
+conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'vulkan-swrast' 'mesa-vdpau')
+# mixing components from different mesa versions is a bad idea, conflict with everything unique provided by extra/mesa
url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
@@ -32,57 +35,11 @@ md5sums=('SKIP'
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2')
-# NINJAFLAGS is an env var used to pass commandline options to ninja
-# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
+# ninja grabs all available cores and leaves almost nothing for other processes.
+# this package uses the environment variable NINJAFLAGS to allow the user to change this behaviour
+# The responsibility to validate the value of NINJAFLAGS lies with the user.
+# If unsure, use NINJAFLAGS=""
-# MESA_WHICH_LLVM is an environment variable that determines which llvm package tree is used to built mesa-git against.
-# Adding a line to ~/.bashrc that sets this value is the simplest way to ensure a specific choice.
-#
-# NOTE: Aur helpers don't handle this method well, check the sticky comments on mesa-git aur page .
-#
-# 1: llvm-minimal-git (aur) preferred value
-# 2: AUR llvm-git
-# 3: llvm-git from LordHeavy unofficial repo
-# 4 llvm (stable from extra) Default value
-#
-
-if [[ ! $MESA_WHICH_LLVM ]] ; then
- MESA_WHICH_LLVM=4
-fi
-
-case $MESA_WHICH_LLVM in
- 1)
- # aur llvm-minimal-git
- makedepends+=('llvm-minimal-git')
- depends+=('llvm-libs-minimal-git')
- optdepends+=('llvm-minimal-git: opencl')
- ;;
- 2)
- # aur llvm-git
- # depending on aur-llvm-* to avoid mixup with LH llvm-git
- makedepends+=('aur-llvm-git')
- depends+=('aur-llvm-libs-git')
- optdepends+=('aur-llvm-git: opencl')
- ;;
- 3)
- # mesa-git/llvm-git (lordheavy unofficial repo)
- makedepends+=('llvm-git' 'clang-git')
- depends+=('llvm-libs-git')
- optdepends+=('clang-git: opencl' 'compiler-rt: opencl')
- ;;
- 4)
- # extra/llvm
- makedepends+=(llvm=11.0.0 clang=11.0.0)
- depends+=(llvm-libs=11.0.0)
- optdepends+=('clang: opencl' 'compiler-rt: opencl')
- ;;
- *)
-esac
-
-
-
-
-
pkgver() {
cd mesa
read -r _ver <VERSION
@@ -99,34 +56,34 @@ prepare() {
build () {
meson setup mesa _build \
- -D b_ndebug=false \
+ -D b_ndebug=true \
-D b_lto=true \
-D buildtype=plain \
--wrap-mode=nofallback \
-D prefix=/usr \
-D sysconfdir=/etc \
-D platforms=x11,wayland \
- -D dri-drivers=i915,i965,r200,r100,nouveau \
- -D gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast,virgl,iris,zink \
- -D vulkan-drivers=amd,intel \
+ -D dri-drivers=[] \
+ -D gallium-drivers=radeonsi,swrast,iris,zink \
+ -D vulkan-drivers=amd,intel,swrast \
-D dri3=enabled \
-D egl=enabled \
-D gallium-extra-hud=true \
- -D gallium-nine=true \
- -D gallium-omx=bellagio \
+ -D gallium-nine=false \
+ -D gallium-omx=disabled \
-D gallium-va=enabled \
- -D gallium-vdpau=enabled \
- -D gallium-xa=enabled \
+ -D gallium-vdpau=disabled \
+ -D gallium-xa=disabled \
-D gallium-xvmc=disabled \
-D gbm=enabled \
-D gles1=disabled \
-D gles2=enabled \
-D glvnd=true \
-D glx=dri \
- -D libunwind=disabled \
+ -D libunwind=enabled \
-D llvm=enabled \
- -D lmsensors=disabled \
- -D osmesa=true \
+ -D lmsensors=enabled \
+ -D osmesa=false \
-D shared-glapi=enabled \
-D gallium-opencl=icd \
-D valgrind=disabled \
@@ -134,8 +91,6 @@ build () {
-D vulkan-device-select-layer=true \
-D tools=[] \
-D zstd=enabled \
- -D debug=false \
- -D b_pgo=off \
-D microsoft-clc=disabled
meson configure _build