summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2022-08-17 16:12:19 +0200
committerLone_Wolf2022-08-17 16:12:19 +0200
commit8846e0dc14ac9c4769cddd538b83c382d93e16c2 (patch)
tree87862526d2912df43935f8d26ea924e897d75ac4 /PKGBUILD
parent69403be4097f808a61a9fa025a7a4fac6bcb9d92 (diff)
downloadaur-8846e0dc14ac9c4769cddd538b83c382d93e16c2.tar.gz
force c++17 to fix build with latest llvm 16
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13c410290dcb..b3771e4c9d06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=22.2.0_devel.154303.e8eb6d13a5d
+pkgver=22.3.0_devel.158187.adb4934d59c3
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto' 'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libxrandr'
@@ -52,15 +52,21 @@ prepare() {
}
build () {
+
+# llvm 16 switchted to c++17 by default in https://github.com/llvm/llvm-project/commit/b4e9977fc18405d4a11cbaf1975bcadbf75920b8
+# use cpp_std=c++17 to force that version
+# can be removed once https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/17966 is merged to master
+
meson setup mesa _build \
-D b_ndebug=true \
-D buildtype=plain \
+ -D cpp_std=c++17 \
--wrap-mode=nofallback \
-D prefix=/usr \
-D sysconfdir=/etc \
-D platforms=x11,wayland \
-D dri-drivers=[] \
- -D gallium-drivers=radeonsi,swrast,iris,zink \
+ -D gallium-drivers=radeonsi,swrast,iris,zink,virgl \
-D vulkan-drivers=amd,intel,swrast \
-D dri3=enabled \
-D egl=enabled \