summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2023-09-19 15:47:06 +0200
committerLone_Wolf2023-09-19 15:47:06 +0200
commitbeb2c7c447957e8e1c78c42ae290379f115f9067 (patch)
treeebcd2baf14aed396913fd7424c2ca86852cc2fe0 /PKGBUILD
parent008523999aaedab9df81ef944e1cf776433d576c (diff)
downloadaur-beb2c7c447957e8e1c78c42ae290379f115f9067.tar.gz
added patches for llvm-18 build failure, see https://gitlab.freedesktop.org/mesa/mesa/-/issues/9833
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08abeba53431..b500745eb6f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=mesa-minimal-git
pkgname=(mesa-minimal-git opencl-rusticl-mesa-minimal-git)
pkgdesc="an open-source implementation of the OpenGL specification, stripped down git version"
-pkgver=23.3.0_devel.177776.210f1e14d5a
+pkgver=23.3.0_devel.177988.4c877ebfe50
pkgrel=1
arch=('x86_64')
makedepends=(git meson ninja libglvnd python-mako xorgproto libxml2 libx11 libva elfutils libxrandr
@@ -27,11 +27,17 @@ url="https://www.mesa3d.org"
license=('custom')
source=("mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git"
'LICENSE'
+ 'llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch'
+ 'llvm18-change-in-CodeGenOpt-structure.patch'
)
md5sums=('SKIP'
- '5c65a0fe315dd347e09b1f2826a1df5a')
+ '5c65a0fe315dd347e09b1f2826a1df5a'
+ 'e9dbaa32b8624c90cd3729e4cb1c5b20'
+ 'f3f0ec23e694afdec23fb7578a093bc3')
sha512sums=('SKIP'
- '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2')
+ '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
+ '7fd42c63283a38a0d55ed208464d14cf71de7518878424e7a1c20a6b0432ec0f5368fbfb171a73744898a24f0dec24b6daeab7ef9c732f1c5a552c419fc5821b'
+ '4b5147ace168fbf6aed091a5839b7bebe46c63ceb9504ff75351f48c98122842ed668ff86a0c919ecea72125719d290628f039b5bdde215445f4b2ce395f8a58')
options=(!emptydirs)
# ninja grabs all available cores and leaves almost nothing for other processes.
@@ -39,6 +45,12 @@ options=(!emptydirs)
# The responsibility to validate the value of NINJAFLAGS lies with the user.
# If unsure, use NINJAFLAGS=""
+prepare() {
+ cd mesa
+ patch --forward --strip=1 --input="${srcdir}"/llvm18-replace-CGFT-with-CodeGenFileType-where-needed.patch
+ patch --forward --strip=1 --input="${srcdir}"/llvm18-change-in-CodeGenOpt-structure.patch
+}
+
pkgver() {
cd mesa
local _ver