summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosiah Schwab2015-09-08 13:36:05 -0700
committerJosiah Schwab2015-09-08 13:36:05 -0700
commit0f33b10897015245dc4dc12b3bfeb02b655bafc9 (patch)
treeed009a88d3e2d663ea53afd25ce6a0159b226735 /PKGBUILD
downloadaur-0f33b10897015245dc4dc12b3bfeb02b655bafc9.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..975529904bc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Original author: Josiah Schwab <jschwab at gmail dot com>
+# Maintainer: Josiah Schwab <jschwab at gmail dot com>
+
+pkgname=mesasdk
+pkgdesc="Software development kit for use with the MESA stellar evolution code"
+pkgver=20150908
+pkgrel=1
+arch=('x86_64')
+url="http://www.astro.wisc.edu/~townsend/static.php?ref=mesasdk"
+provides=('mesasdk')
+depends=('binutils' 'make' 'perl' 'libx11' 'zlib' 'tcsh' 'glibc')
+install=mesasdk.install
+source=("http://www.astro.wisc.edu/~townsend/resource/download/${pkgname}/${pkgname}-x86_64-linux-${pkgver}.tar.gz")
+sha1sums=('43781c59f71b2899a763bd0a741269b9c61ab3a6')
+options=('!strip')
+
+package() {
+ mkdir -p ${pkgdir}/opt
+ tar --extract --file ${pkgname}-x86_64-linux-${pkgver}.tar.gz --directory ${pkgdir}/opt
+}