summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2020-04-02 18:00:41 +0200
committerbartus2020-04-02 18:11:46 +0200
commit0579e37ec3dc1dabb969ae1fa5fa72d54cc9804e (patch)
treee634f456d7fa1b2a20bf27a920633658fd56effe /PKGBUILD
parentd5a1dce77f290c450506149e00a7168b91f501a0 (diff)
downloadaur-0579e37ec3dc1dabb969ae1fa5fa72d54cc9804e.tar.gz
Drop upstream applied patch
remove old desktop file and update depends.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 276d6c085ed6..2dfddb03b0e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
_name="meshlab"
pkgname="$_name-git"
-pkgver=2020.03.r36.gd0fa7a31f
-pkgrel=2
+pkgver=2020.04.r7.g3e89ebb8d
+pkgrel=1
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
url="https://www.meshlab.net"
conflicts=('meshlab')
provides=('meshlab')
license=('GPL2')
-depends=('bzip2' 'desktop-file-utils' 'glew' 'glu' 'openssl-1.0' 'qt5-base' 'qt5-declarative' 'qt5-script' 'qt5-xmlpatterns')
+depends=('bzip2' 'glew' 'glu' 'openssl-1.0' 'qt5-base' 'qt5-declarative' 'qt5-script' 'qt5-xmlpatterns')
makedepends=('cmake' 'eigen3' 'ninja' 'git' 'muparser' 'levmar' 'lib3ds' 'mpir')
optdepends=('u3d: for U3D and IDTF file support'
'lib3ds: for Autodesk`s 3D-Studio r3 and r4 .3DS file support'
@@ -22,18 +22,15 @@ optdepends=('u3d: for U3D and IDTF file support'
#also create openctm(aur) jhead-lib structuresynth-lib to handle last dep
source=("$_name::git+https://github.com/cnr-isti-vclab/meshlab.git"
"vcglib::git+https://github.com/cnr-isti-vclab/vcglib.git"
- "desktop.patch"
- "meshlab.desktop")
+ )
sha256sums=('SKIP'
'SKIP'
- '1690f70118c985da61595b615635472144c4d0b3ddcefb515b9f230c106961b5'
- '030ab1dcafb7d793bed3bc455497208addadf1091a4619576fe7e044aed4231a')
+ )
prepare() {
git -C "${srcdir}/${_name}" submodule init
git -C "${srcdir}/${_name}" config submodule.vcglib.url "$srcdir"/vcglib
git -C "${srcdir}/${_name}" submodule update
- git -C "${srcdir}/${_name}" apply -v "${srcdir}/desktop.patch"
}
pkgver() {