summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2021-08-03 20:08:43 +0200
committerbartus2021-08-03 20:08:43 +0200
commit3cc913736dd17d7f0149421f2e91b9a1b46d8dbd (patch)
tree9efb18b6176e6955d9c5798ed60e5fedb9766f6e /PKGBUILD
parent452d66560869e6cb0c0592c3ef98b49ad96cfd4c (diff)
downloadaur-3cc913736dd17d7f0149421f2e91b9a1b46d8dbd.tar.gz
Switch to cx_freeze-qfix, back port fix for cx_freeze:3.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a86726003120..7862a9aa44df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ name=meshroom
fragment="#tag=v2021.1.0"
pkgname=${name}
pkgver=${fragment#\#tag=v}
-pkgrel=5
+pkgrel=6
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
url="https://alicevision.github.io/"
@@ -14,18 +14,20 @@ groups=()
_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg qt5-charts)
#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision alembic openimageio python python-psutil "${_depends_qt[@]}")
-makedepends=(git cmake python-{cx_freeze,idna,setuptools} patchelf)
+makedepends=(git cmake python-{cx-freeze-qfix,idna,setuptools} patchelf)
source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git"
"git+https://github.com/alicevision/qmlAlembic.git"
"pyside_property_error.patch"
+ "Fix-incompatibility-with-recent-cx_Freeze.patch"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc')
+ 'e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc'
+ '40ee489604627e5be1b8ce5f3fdd4b1828a5588427fda298b61aa37beb9125c5')
prepare() {
cd "${srcdir}"/${pkgname}
@@ -42,6 +44,8 @@ prepare() {
# avoid bug in pyside 5.15.2 (https://bugreports.qt.io/browse/PYSIDE-1426)
patch -Np1 -i "$srcdir"/pyside_property_error.patch
+ # back port b9a7174886d7a215818f382f9d5c05226f86a3ff
+ patch -Np1 -i "$srcdir"/Fix-incompatibility-with-recent-cx_Freeze.patch
}
build() {