summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChemicalXandco2021-03-01 17:27:37 +0000
committerbartoszek2021-03-10 10:03:18 +0100
commit65f6dd198b6acb702c3018e525f7922aaffe4452 (patch)
tree35000cff1e501931ab05a02dc5049922fd77286e /PKGBUILD
parented31807e5d342f791904fab1e063e8214308e39c (diff)
downloadaur-65f6dd198b6acb702c3018e525f7922aaffe4452.tar.gz
update to 2021.1.0 and avoid bug in pyside 5.15.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9b77cbc4963..bbba7b3911bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
name=meshroom
#fragment="#commit=9bd70ed8ace83c6dde174178e17c5147bb50248f"
-fragment="#tag=v2020.1.1"
+fragment="#tag=v2021.1.0"
pkgname=${name}
pkgver=${fragment#\#tag=v}
-pkgrel=2
+pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
url="https://alicevision.github.io/"
license=('MPL2')
groups=()
-_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
+_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg qt5-charts)
#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision alembic openimageio python python-psutil ${_depends_qt[@]})
makedepends=(git cmake python-{cx_freeze,idna,setuptools})
@@ -19,11 +19,13 @@ source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git"
"git+https://github.com/alicevision/qmlAlembic.git"
+ "pyside_property_error.patch"
)
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc')
prepare() {
cd "${srcdir}"/${pkgname}
@@ -32,6 +34,9 @@ prepare() {
sed -i "s:'ALICEVISION_SENSOR_DB', '':'ALICEVISION_SENSOR_DB', '/usr/share/aliceVision/cameraSensors.db':g" meshroom/nodes/aliceVision/*.py
sed -i '1 i\#include <cmath>' "${srcdir}"/QtOIIO/src/jetColorMap.hpp
sed -i 's|imageformats|plugins/imageformats|' "${srcdir}"/QtOIIO/src/imageIOHandler/CMakeLists.txt
+
+ # avoid bug in pyside 5.15.2 (https://bugreports.qt.io/browse/PYSIDE-1426)
+ patch -Np1 -i "$srcdir"/pyside_property_error.patch
}
build() {
@@ -39,10 +44,10 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX="/usr/lib/qt/" -DCMAKE_BUILD_TYPE=Release .
make
- cd "${srcdir}"/qmlAlembic
+ cd "${srcdir}"/qmlAlembic
cmake -DCMAKE_INSTALL_PREFIX="/usr/lib/qt/" -DCMAKE_BUILD_TYPE=Release .
make
-
+
cd "${srcdir}"/${pkgname}
python setup.py build
}
@@ -52,7 +57,7 @@ package() {
cd "${srcdir}"/QtOIIO
make DESTDIR="${pkgdir}" install
- cd "${srcdir}"/qmlAlembic
+ cd "${srcdir}"/qmlAlembic
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/${pkgname}