summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-08-02 22:17:54 +0200
committerbartus2018-08-02 22:17:54 +0200
commita058b77eec4b1fbb4f61b454e8211a9fb876c09b (patch)
tree97c9f2f67e6b5e2f032371f2f7955641963a798a /PKGBUILD
downloadaur-a058b77eec4b1fbb4f61b454e8211a9fb876c09b.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d27646d85d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
+
+name=meshroom
+#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
+fragment="#branch=develop"
+pkgname=${name}
+pkgver=r762.9bd70ed
+pkgrel=1
+pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
+arch=('i686' 'x86_64')
+url="http://alicevision.github.io/"
+license=('MPL2')
+groups=()
+depends=(alice-vision python python-psutil python-pyside2)
+makedepends=(git python-setuptools python-cx_freeze)
+source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
+ "voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
+ )
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${srcdir}/${pkgname}
+ msg2 "Hardcode camera_database and voctree default value"
+ sed -i "s:'ALICEVISION_VOCTREE', '':'ALICEVISION_VOCTREE', '/usr/share/${pkgname}/vlfeat_K80L3.SIFT.tree':g" meshroom/nodes/aliceVision/*.py
+ sed -i "s:'ALICEVISION_SENSOR_DB', '':'ALICEVISION_SENSOR_DB', '/usr/share/aliceVision/sensor_width_camera_database.txt':g" meshroom/nodes/aliceVision/*.py
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+ python setup.py build
+}
+
+
+package() {
+ cd ${srcdir}/${pkgname}
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
+ install -Dm644 -t ${pkgdir}/usr/share/${pkgname} ${srcdir}/voctree/vlfeat_K80L3.SIFT.tree
+}
+# vim:set ts=2 sw=2 et: