summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-08-06 22:01:16 +0200
committerbartus2018-08-06 22:01:16 +0200
commita6fdf040abdc164135de187efa72ac027d175678 (patch)
tree7fb771932442c88b3ff7737e1952013248300c4b /PKGBUILD
parent497bfca73ee94a5b11cb0d9fdf1e6b10d2f42171 (diff)
downloadaur-a6fdf040abdc164135de187efa72ac027d175678.tar.gz
drop upstream applied patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfd9db2b1c97..826b173550d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ name=meshroom
#fragment="#commit=9bd70ed8ace83c6dde174178e17c5147bb50248f"
fragment="#branch=develop"
pkgname=${name}
-pkgver=r781.ef591dd
+pkgver=r783.80412d5
pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
@@ -12,15 +12,14 @@ url="http://alicevision.github.io/"
license=('MPL2')
groups=()
_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
+#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision python python-psutil ${_depends_qt[@]})
makedepends=(git python-setuptools python-cx_freeze)
source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
- "freezer.patch"
)
md5sums=('SKIP'
- 'SKIP'
- 'b11eb0ff4db95d1130e324f408b6702e')
+ 'SKIP')
pkgver() {
cd "$pkgname"
@@ -32,7 +31,6 @@ prepare() {
msg2 "Hardcode camera_database and voctree default value"
sed -i "s:'ALICEVISION_VOCTREE', '':'ALICEVISION_VOCTREE', '/usr/share/${pkgname}/vlfeat_K80L3.SIFT.tree':g" meshroom/nodes/aliceVision/*.py
sed -i "s:'ALICEVISION_SENSOR_DB', '':'ALICEVISION_SENSOR_DB', '/usr/share/aliceVision/sensor_width_camera_database.txt':g" meshroom/nodes/aliceVision/*.py
- git apply ${srcdir}/freezer.patch
}
build() {