summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2021-08-10 12:59:11 +0200
committerbartus2021-08-10 12:59:11 +0200
commite85a5c61aded8817129b78775d8e22e7d263f71a (patch)
tree4dcc17c8708f98f5bdc0b81f346197ef916aa2c5 /PKGBUILD
parent708a6053685b23e114dcd0969a4d2397dabfbf20 (diff)
downloadaur-e85a5c61aded8817129b78775d8e22e7d263f71a.tar.gz
Add DISABLE_CUDA env var, fix missing `boost` makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 575935ab8dbb..9ebd84cef75d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,8 @@
# Use: aurutils --margs=VAR1=0,VAR2=1
# Use: VAR1=0 VAR2=1 pamac
-((ENABLE_QTALICEVISION)) && component+=(qtAliceVision)
+((ENABLE_QTALICEVISION)) && components+=(qtAliceVision)
+((DISABLE_CUDA)) && msg2 "DISABLE_CUDA valid only if 'alice-vision' was build with DISABLE_CUDA=1" >&2
name=meshroom
#fragment="#commit=9bd70ed8ace83c6dde174178e17c5147bb50248f"
@@ -25,7 +26,8 @@ _depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt
#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision alembic openimageio python python-psutil "${_depends_qt[@]}")
makedepends=(git cmake python-{cx-freeze-qfix,idna,setuptools} patchelf)
-((ENABLE_QTALICEVISION)) && makedepends+=(popsift coin-or-lemon)
+((ENABLE_QTALICEVISION)) && makedepends+=(coin-or-lemon boost)
+((ENABLE_QTALICEVISION&!DISABLE_CUDA)) && makedepends+=(popsift)
source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git${fragment}"