summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsyne2016-09-05 16:29:10 +0300
committersyne2016-09-05 16:29:10 +0300
commit541b1aabf7f3192c49055e26924dceba16b4a69f (patch)
treefedc348b56f453cdaf200ce46bc8a8518e6a979e /PKGBUILD
parent3cabec28b6b596fc40f735aee7211d2160d224c6 (diff)
downloadaur-541b1aabf7f3192c49055e26924dceba16b4a69f.tar.gz
Tried to follow Java packaging rules, but no dice
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 25 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5729d7f7f16..fc413d664ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,40 @@
# Contributor: Mick Elliot <micke at sfu dot ca>
# Maintainer: syne <madlikene at aim dot com>
pkgname=mesquite
-pkgver=3.04
-_pkgver=304_Linux
-buildver=build725
+pkgver=3.10
+_pkgver=310-Linux
+buildver=build-765
pkgrel=1
-pkgdesc="A software package for evolutionary biology, designed to analyze comparative data about organisms"
+pkgdesc="A modular, extendible software for evolutionary biology, designed to help biologists organize and analyze comparative data about organisms"
arch=('any')
-url="http://www.mesquiteproject.org/"
-license=('LGPL')
+url="http://mesquiteproject.wikispaces.com"
+license=('(L)GPL')
depends=('java-runtime')
-source=("https://github.com/MesquiteProject/MesquiteCore/releases/download/$pkgver$buildver/Mesquite$_pkgver.tar.gz"
- "${pkgname}.png"
- "${pkgname}.desktop"
- "${pkgname}.sh")
-md5sums=('432bc66e03d68a7e7f0289510d603ce0'
+source=(https://github.com/MesquiteProject/MesquiteCore/releases/download/v$pkgver-$buildver/Mesquite$_pkgver.tgz
+ $pkgname.png
+ $pkgname.desktop
+ $pkgname.sh
+ )
+md5sums=('6d993e949730451991c8f754ead4b852'
'8b62ba93f95aab14a8643bf5b939f465'
- 'ef6d47b0a7aa27329165b1185982678e'
- '79604254490c2d8bbcbf54719ac99b6a')
+ '279160bcf1544a78e0b0372279bfa68d'
+ 'f6ff62edbf95e40d21c7bceadb35ecfe'
+ )
package() {
- cd "${srcdir}/Mesquite_Folder"
-
+ cd $srcdir/Mesquite_Folder
+ # Remove bundled shell script and install own
+ rm -rf $pkgdir/$pkgname.sh
+ install -Dm755 ../$pkgname.sh $pkgdir/usr/bin/$pkgname
+
# Install program files
- mkdir -p "${pkgdir}/usr/share/${pkgname}"
- cp -r * "${pkgdir}/usr/share/${pkgname}"
- find "${pkgdir}/usr/share/${pkgname}" -type f -exec chmod 644 '{}' \;
+ mkdir -p $pkgdir/usr/share/$pkgname
+ cp -r * $pkgdir/usr/share/$pkgname
+ find $pkgdir/usr/share/$pkgname -type f -exec chmod 644 '{}' \;
- # Install a launcher
- install -Dm755 ../${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
# Install a desktop entry
- install -Dm644 ../${pkgname}.png "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 ../${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 ../$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 ../$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
}