summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2022-03-05 18:33:49 +0100
committerPeter Mattern2022-03-05 18:33:49 +0100
commit95e86c8dc71de24e87ca1fc9654af752d9b02eac (patch)
tree1b730ebfed213a6c6f4390358b5ebe55346ae683 /PKGBUILD
parent20ee8f9a56bba1125f9a94b6de382d3dc70064a3 (diff)
downloadaur-95e86c8dc71de24e87ca1fc9654af752d9b02eac.tar.gz
Fix and update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6961a7bf3108..3ec4fa78d8ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
_pkgname=meteo-qt
pkgname=$_pkgname-git
-pkgver=0.8.1.13.g886e154
+pkgver=3.1.10.g0a83f51
pkgrel=1
pkgdesc='System tray application for weather status information'
arch=('any')
url='https://github.com/dglent/meteo-qt'
license=('GPL3')
-depends=('libxkbcommon-x11' 'python-lxml' 'python-pyqt5' 'python-sip' 'python-urllib3')
-makedepends=('python' 'qt5-tools')
+depends=('python-lxml' 'python-pyqt5' 'python-sip4' 'python-urllib3')
+makedepends=('git' 'qt5-tools')
+optdepends=('qt5-translations: translations of some native UI components')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=('git+https://github.com/dglent/meteo-qt.git')
+source=("git+${url}.git")
sha256sums=("SKIP")
pkgver() {
@@ -24,3 +25,4 @@ package() {
cd $_pkgname
python setup.py install --root $pkgdir
}
+