summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Lanham2017-10-29 11:08:31 -0700
committerNick Lanham2017-10-29 11:08:31 -0700
commite11317275a683570aec3891e886f3e2ff6e9d0f7 (patch)
tree0e6c67b6c7a954bc020bc3db181e1914aa24a63d /PKGBUILD
downloadaur-meteocons.tar.gz
Initial commit, working PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c720751508a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nick Lanham <nickl@berkeley.edu>
+
+pkgbase=meteocons
+pkgname=(ttf-meteocons otf-meteocons)
+pkgver=1.0
+pkgrel=1
+pkgdesc="A set of over 40 weather icons"
+url="http://www.alessioatzeni.com/meteocons/"
+license=('custom')
+arch=('any')
+depends=('fontconfig')
+source=("http://www.alessioatzeni.com/meteocons/res/download/meteocons-font.zip"
+ "License.txt")
+sha256sums=('a9550332979f36a572ee0693ab1c07e44e47d5ac72c424f6db1e81cca2a1c74b'
+ '7aa921e93c2849ddb4e1a383063bf23c81a9f1dd1aebd3674caceb061b51d104')
+
+package_ttf-meteocons() {
+ install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/License.txt"
+ cd "meteocons-font/FONT/Desktop-font"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF"
+}
+
+package_otf-meteocons() {
+ install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/License.txt"
+ cd "meteocons-font/FONT/Desktop-font"
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 *.otf "$pkgdir/usr/share/fonts/OTF"
+}