summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJacopo Nespolo2024-02-14 23:59:55 +0900
committerJacopo Nespolo2024-02-15 00:00:14 +0900
commitb009463c709683823f04e02857e5e8e6f34329ba (patch)
treec752d98a22e9d4aeb976ea7d5257ee23acb0054b /PKGBUILD
parent994809c0c8b8c8d5cd1d3ead59716af908203b32 (diff)
downloadaur-b009463c709683823f04e02857e5e8e6f34329ba.tar.gz
more orthodox package
merges loqs' advice
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f21ba57bf95a..117a85ed197d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Jacopo Nespolo <$lowercase_first_name at movimento dash centrale dot it>
+# Contributor: loqs
pkgname=mfem-glvis
_pkgname=glvis
pkgver=4.2
@@ -7,36 +8,32 @@ pkgdesc="A lightweight tool for accurate and flexible finite element visualizati
arch=("x86_64")
url="https://glvis.org"
license=('BSD-3-Clause')
-depends=(mfem openmpi libglvnd sdl2 glew libpng freetype2 fontconfig gcc-libs glibc)
+depends=(libpng freetype2 sdl2 mfem glew gcc-libs libglvnd fontconfig glibc)
makedepends=(cmake glm libxi ninja tinyxxd)
-_repo=https://github.com/GLVis/glvis
-source=(${_pkgname}-${pkgver}.tar.gz::${repo}/archive/refs/tags/v${pkgver}.tar.gz)
+source=(https://github.com/GLVis/$_pkgname/archive/v$pkgver/${_pkgname}-${pkgver}.tar.gz)
md5sums=('a228c65c285e7a66e38b1ec2f2812842')
prepare() {
- # Backporting upstream commit 92bab4c
# "Fix installation with CMake on non-APPLE platforms"
- cd $_pkgname-$pkgver
- echo -e "318a319\n> if (APPLE)\n339a341\n> endif (APPLE)" | patch CMakeLists.txt
+ sed -i '/GLVIS_APP_ICON/,+20d' $_pkgname-$pkgver/CMakeLists.txt
}
build() {
cmake \
-S "$_pkgname-$pkgver" \
-B build \
+ -G Ninja \
-D CMAKE_BUILD_TYPE:STRING=Release \
-D CMAKE_INSTALL_PREFIX:STRING=/usr \
-D GLVIS_USE_LIBTIFF=OFF \
- -D GLVIS_USE_LIBPNG=ON
+ -D GLVIS_USE_LIBPNG=ON \
+ -Wno-dev
- local N_CORES=$(grep "core id" /proc/cpuinfo | uniq | wc -l)
- cmake --build build --parallel $N_CORES
+ cmake --build build
}
package() {
- ln -s build/glvis build/GLVis
- ls build
- DESTDIR="${pkgdir}" cmake --build build --target install -v
+ DESTDIR="${pkgdir}" cmake --install build -v
install \
-v \