summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexei Colin2018-01-13 22:46:40 -0500
committerAlexei Colin2018-01-13 22:46:40 -0500
commitea7d8ee4bb8109fa2051f6372b56fe5461969336 (patch)
tree45c035c572eb469c495ce6888e8ab5ed9bcdacb0 /PKGBUILD
parent32ebaac9c7e01b78c4c50fafdb6d87d46d8934c1 (diff)
downloadaur-ea7d8ee4bb8109fa2051f6372b56fe5461969336.tar.gz
update upstream url, fix compile error with inlines
add support for aarch64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32dc15166275..e9fb91c832d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,28 +6,38 @@ pkgrel=5
pkgdesc="Mgetty is a versatile program to handle all aspects of a modem under Unix."
url="http://mgetty.greenie.net/"
license=('GPL')
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
depends=('glibc' 'logrotate' 'udev' 'netpbm')
makedepends=('make')
install=mgetty.install
-source=(http://fossies.org/unix/misc/$pkgname$pkgver-Jun05.tar.gz
+source=(ftp://mgetty.greenie.net/pub/mgetty/source/1.1/${pkgname}${pkgver}-Jun05.tar.gz
Makefile.patch
config.patch
policy.patch
+ no-inline.patch
+ aarch64.patch
90-mgetty.rules
- mgetty@.service)
+ mgetty@.service)
md5sums=('4df2eb47bd6d5318d3d642572ab56e51'
'eaa2b17d77ca099ebb7e92cf2006f6c1'
'd40de3f241a2851f091e0046cb7f28c0'
'5556e5e88c784e75acb14ab998d7eb1a'
+ '4291e988c7e15c1e93ac86b6efe5818b'
+ '8756ace492fb86ba70ed3a5c4b980b0b'
'4b73a5654db86a34a8dccdf5f55c699c'
'cbc70329924235e8f2e6302c859d59a6')
-build() {
+prepare() {
cd $srcdir/$pkgname-$pkgver
cp policy.h-dist policy.h
patch -Np0 -i ../../config.patch
patch -Np0 -i ../../policy.patch
+ patch -p1 < ../../no-inline.patch
+ patch -p1 < ../../aarch64.patch
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
make
}
@@ -36,6 +46,8 @@ package() {
mkdir -p $pkgdir/var/spool
make prefix=$pkgdir/usr spool=$pkgdir/var/spool CONFDIR=$pkgdir/etc/mgetty+sendfax FAX_OUT_USER=0 install
rm -f $pkgdir/usr/bin/g3topbm
+ mv $pkgdir/usr/sbin/* $pkgdir/usr/bin/
+ rm -r $pkgdir/usr/sbin
install -D -m644 $srcdir/90-mgetty.rules $pkgdir/etc/udev/rules.d/90-mgetty.rules
install -D -m644 $srcdir/mgetty@.service $pkgdir/usr/lib/systemd/system/mgetty@.service
}