summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsukso961002016-08-31 17:34:39 +0900
committersukso961002016-08-31 17:34:39 +0900
commit8477e7e8c3453e51e2c7ef0ae104809853353541 (patch)
tree44bd66cc8a19f6b66ccff5d7f5a6c90ed9fb5f56 /PKGBUILD
parenteceff2a23e28f8f62c9e91ac3c2a73642ff9fe8f (diff)
downloadaur-8477e7e8c3453e51e2c7ef0ae104809853353541.tar.gz
Updates Source URL and sha256sums
- Thanks to blainester <theblainestory@gmail.com> for the contribution
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50cc3c482524..5058a9906388 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Youngbin Han <sukso96100@gmail.com>
+# Contributor: blainester <theblainestory@gmail.com>
pkgname=micro
-pkgver=0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc="A modern and intuitive terminal-based text editor"
arch=('x86_64' 'i686')
@@ -9,13 +10,12 @@ license=('MIT')
optdepends=(xclip)
conflicts=("micro-git")
-if [[ $CARCH == 'x86_64' ]]; then
- source=(http://zbyedidia.webfactional.com/micro/binaries/micro-linux64.tar.gz)
-else
- source=(http://zbyedidia.webfactional.com/micro/binaries/micro-linux32.tar.gz)
-fi
+source_x86_64=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux64.tar.gz")
+source_i686=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux32.tar.gz")
+
+sha256sums_x86_64=('1d59797bfb47306b9068e5aec6d1e1c3c8b3e974a05029f4386dd3c6b519a765')
+sha256sums_i686=('7c493f72311470b526d03df9bbd980e01b21668318fbee94ed58f2014b7bc0a7')
-md5sums=(SKIP)
package(){
install -Dm755 $srcdir/$pkgname/micro "$pkgdir/usr/bin/micro"
install -Dm644 $srcdir/$pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"