summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEvan Anderson2015-08-25 20:51:59 -0400
committerEvan Anderson2015-08-25 20:52:59 -0400
commit03722ac104918fc79d2ff0362b2358268229f009 (patch)
treed93e289c82f7d349465778572941fbf0bcb1af31 /PKGBUILD
downloadaur-03722ac104918fc79d2ff0362b2358268229f009.tar.gz
Initial commit
Signed-off-by: Evan Anderson <evananderson@thelinuxman.us>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5bd07be04ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Evan Anderson <evananderson@thelinuxman.us>
+# Former maintainer: David Manouchehri <david@davidmanouchehri.com>
+# Former maintainer: BxS <bxsbxs at gmail dot com>
+
+pkgname=microchip-mplabc18-bin
+pkgver=3.40
+pkgrel=1
+pkgdesc="C compiler for PIC18 MCUs"
+arch=(i686 x86_64)
+url=http://www.microchip.com/c18
+license=(custom)
+[[ $CARCH = x86_64 ]] && depends=(lib32-gcc-libs)
+provides=(mplabc18)
+conflicts=(mplabc18)
+options=(!strip docs libtool emptydirs !zipman)
+install=$pkgname.install
+instdir=/opt/microchip/mplabc18/v$pkgver
+installer=mplabc18-v$pkgver-linux-full-installer.run
+source=(https://bitbucket.org/simbuckone/simbuckbaseproject/downloads/$installer)
+md5sums=(f29df9a4e5c9641a8909bd0a5452d4a9)
+
+package() {
+ echo -e "Creating the Package\n Please wait..."
+
+ cd $pkgdir
+
+ mkdir -p $pkgdir$instdir
+
+ chmod 0755 $srcdir/$installer
+ echo -e "\n\n\n\n\n\n\n\n\n\ny\n$pkgdir$instdir\ny" > inst_input
+ $srcdir/$installer --mode text < inst_input &> /dev/null
+ rm inst_input
+
+ rm $pkgdir$instdir/Uninstall*
+
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ ln -s $instdir/MPLABC18CompilerLicense.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}