summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Keen2018-01-04 17:40:24 -0500
committerKyle Keen2018-01-04 17:40:24 -0500
commit14c8e5b15cb48baf7f49d4545348ff3c3451887e (patch)
tree67415db200ec7719ea895a0e640cdc918c7b1c65 /PKGBUILD
parentfe4121fbeee393440de8a98fb9a98685fb63b70a (diff)
downloadaur-14c8e5b15cb48baf7f49d4545348ff3c3451887e.tar.gz
update to 1.9.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ea17491f566..cd5c8f2bf0ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kyle Keen <keenerd@gmail.com>
pkgbase=micropython
pkgname=(micropython micropython-lib)
-pkgver=1.9.2
-_libver=1.9
+pkgver=1.9.3
+_libver=1.9.3
# stupid submodules
_axver=1.8.2
_ffiver=3.2.1
@@ -21,8 +21,8 @@ source=("mpy-$pkgver.tgz::https://github.com/micropython/micropython/archive/v$p
"bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz") # submodule with no releases!
# What about the lwip submodule? The repo is GONE. You didn't need an IP stack anyway.
# Maybe http://download.savannah.gnu.org/releases/lwip/lwip-2.0.0.zip is it?
-md5sums=('2aa8cbe99ea94982f9bb6ab2489ffbd8'
- '56dff4526bc435bd5a4c74bf52cbd5e1'
+md5sums=('64f6f32939db936a7c3ef9e78de89f4a'
+ '1752ce13e851a671a07ce3f7a807b21c'
'e11da4ef04499030d1eff69b474f34f0'
'9066486bcab807f7ddaaf2596348c1db'
'SKIP')
@@ -41,7 +41,7 @@ prepare() {
ln -s "$srcdir/berkeley-db-1.xx-embedded" berkeley-db-1.xx
# fix makefile
- cd "$srcdir/micropython-$pkgver/unix"
+ cd "$srcdir/micropython-$pkgver/ports/unix"
sed -i 's|/local||' Makefile
sed -i 's|git clean -d -x -f||' Makefile
@@ -52,7 +52,7 @@ prepare() {
}
build() {
- cd "$srcdir/micropython-$pkgver/unix"
+ cd "$srcdir/micropython-$pkgver/ports/unix"
make libffi
#make V=1 deplibs
make
@@ -61,12 +61,12 @@ build() {
}
check() {
- cd "$srcdir/micropython-$pkgver/unix"
+ cd "$srcdir/micropython-$pkgver/ports/unix"
#make test
}
package_micropython() {
- cd "$srcdir/micropython-$pkgver/unix"
+ cd "$srcdir/micropython-$pkgver/ports/unix"
make DESTDIR="$pkgdir" install
cd "$srcdir/micropython-$pkgver"