summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2019-06-05 10:27:00 +0200
committerChristopher Arndt2019-06-05 10:27:00 +0200
commit84f0d3a621b3045bfa51007d2e66aa9fc939d401 (patch)
treec1ea07cd7468ca54448ff4390e57380b1a1760d9 /PKGBUILD
parent39154baf70bdbd10a53bd117ae0873994bda67f7 (diff)
downloadaur-84f0d3a621b3045bfa51007d2e66aa9fc939d401.tar.gz
Fix build (mpy-cross needs to be compiled separately again)
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83c5b8d7a461..d0c29f5310ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname="micropython"
pkgname="${_pkgname}-git"
-pkgver=1.10.3e25d611e
+pkgver=1.11.62f004ba4
pkgrel=1
epoch=1
pkgdesc="A Python 3 implementation for microcontrollers and constrained environments (Unix version)."
@@ -34,13 +34,14 @@ prepare() {
}
build() {
- cd "${srcdir}/${_pkgname}/ports/unix"
- make
+ cd "${srcdir}/${_pkgname}"
+ ( cd mpy-cross; make; )
+ ( cd ports/unix; make; )
}
package() {
- cd "${srcdir}/${_pkgname}/ports/unix"
- make PREFIX="$pkgdir/usr" install
- install "${srcdir}/${_pkgname}/mpy-cross/mpy-cross" "$pkgdir/usr/bin"
- install -Dm644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/${_pkgname}"
+ ( cd ports/unix; make PREFIX="$pkgdir/usr" install; )
+ install mpy-cross/mpy-cross "$pkgdir/usr/bin"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}