summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-10-23 09:19:54 +0200
committerChristopher Arndt2022-10-23 09:19:54 +0200
commit887964ec9c563a7e7e101a08c00c7fd546d3ecec (patch)
tree0be0211762045f7a79615fe3952e02c27f0d6473 /PKGBUILD
parentb2617dc40012aa053e0284aca3b7f62d6b75a618 (diff)
downloadaur-887964ec9c563a7e7e101a08c00c7fd546d3ecec.tar.gz
Added `check()` function and excluded some failing tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ed0ea36ce97..b6de76921551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname='micropython'
pkgname=$_pkgname-git
-pkgver=1.19.1.r451.gbdbc44474f
+pkgver=1.19.1.r560.g68f166dae9
pkgrel=1
epoch=1
pkgdesc='A Python 3 implementation for microcontrollers and constrained environments (Unix version)'
@@ -54,6 +54,15 @@ build() {
( cd ports/unix; make)
}
+check() {
+ cd $_pkgname/tests
+ # Float representation does not match CPython
+ export MICROPY_MICROPYTHON=../ports/unix/build-standard/micropython
+ ./run-tests.py \
+ --exclude float_parse \
+ --exclude float_parse_doubleprec
+}
+
package() {
cd $_pkgname
( cd ports/unix; make PREFIX="$pkgdir"/usr install; )