summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksandar Trifunovic2019-07-14 16:33:44 +0200
committerAleksandar Trifunovic2019-07-14 16:36:57 +0200
commit5805af73280b4319f95a848da4f72080a85056fa (patch)
tree8e278d67b2c345101b68c41f7820856ddd855551 /PKGBUILD
parent1fbc08bad039827884484bffc00a9f7e12a56880 (diff)
downloadaur-5805af73280b4319f95a848da4f72080a85056fa.tar.gz
Restore usage of system catch to avoid installing catch in build dir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 357f26e82c19..35fdaa96d2ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,16 @@ pkgdesc="C++ Core Guidelines Support Library"
arch=('any')
url="https://github.com/Microsoft/GSL"
license=('MIT')
-makedepends=('cmake' 'git')
-source=("$url/archive/v${pkgver}.tar.gz")
-sha256sums=('6cce6fb16b651e62711a4f58e484931013c33979b795d1b1f7646f640cfa9c8e')
+makedepends=('cmake' 'catch2')
+source=("https://github.com/Microsoft/GSL/archive/v${pkgver}.tar.gz"
+ "use_system_catch2.patch")
+sha256sums=('6cce6fb16b651e62711a4f58e484931013c33979b795d1b1f7646f640cfa9c8e'
+ '9ebdc1b3628bbdce82e3be469c183cd0d94d3d8964189aad71dac5d7e94d9f58')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/use_system_catch2.patch"
+}
build() {
cd "$_pkgname-$pkgver"