summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2016-08-21 22:24:50 +0200
committerSebastiaan Lokhorst2016-08-21 22:24:50 +0200
commit92b932da04f16e0102992c05274410f0985ceec7 (patch)
tree6b919e31074ac53fc65f4add5594e1ae22ea9f70 /PKGBUILD
downloadaur-92b932da04f16e0102992c05274410f0985ceec7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..283d69a7b271
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+
+_gitname=gsl
+pkgname=microsoft-gsl-git
+pkgver=r323.5112ba0
+pkgrel=1
+pkgdesc="Microsoft's Guidelines Support Library (GSL)"
+arch=('i686' 'x86_64')
+url='https://github.com/Microsoft/GSL'
+license=('MIT')
+
+source=("$_gitname::git+https://github.com/Microsoft/GSL.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -d "$pkgdir/usr/include"
+ cp -r "gsl" "$pkgdir/usr/include"
+}