summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGomasy2018-03-13 16:07:00 +0900
committerGomasy2018-03-13 16:07:00 +0900
commitc496f08f380210a9c3b556b073ef5c616b3bd1ad (patch)
tree8a62e07b948aeecbaec1c32c180122ec96d9e2d3 /PKGBUILD
parent8617597d6fe46ab98226233ac4fc16dc08697c85 (diff)
downloadaur-c496f08f380210a9c3b556b073ef5c616b3bd1ad.tar.gz
Fix depends and add --without test
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38f6c5e73964..5c10b9d3e335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=mikutter
pkgver=3.6.5
-pkgrel=4
+pkgrel=5
pkgdesc="a moest twitter client"
arch=('i686' 'x86_64')
url="http://mikutter.hachune.net/"
license=('MIT')
-depends=('ruby-bundler')
+depends=('gtk2' 'ruby-bundler')
makedepends=('gobject-introspection')
optdepends=('alsa-utils: sound notification support'
'libnotify: notify support')
@@ -17,16 +17,20 @@ source=(
http://mikutter.hachune.net/bin/$pkgname.`echo "$pkgver" | tr "_" '-'`.tar.gz
mikutter.desktop
)
+_gemdir="vendor/bundle/ruby/`ruby -e'print Gem.dir.match(/^.+\/(.+?)$/)[1]'`"
build() {
cd "$pkgname"
- bundle install --path vendor/bundle --no-cache
+ gem install --no-document --no-user-install -i $_gemdir rake
+ bundle install --path vendor/bundle --without test
+
+ rm -rf $gemdir/{build_info,cache,doc}
}
package() {
mkdir "$pkgdir/opt"
cp -r "$srcdir/$pkgname" "$pkgdir/opt"
- cp -r $srcdir/$pkgname/vendor/bundle/ruby/*/gems/twitter-text-*/config "$pkgdir/opt/$pkgname/"
+ cp -r $srcdir/$pkgname/$_gemdir/gems/twitter-text-*/config "$pkgdir/opt/$pkgname/"
mkdir -p "$pkgdir/usr/bin"
cat <<'EOF' > "$pkgdir/usr/bin/mikutter"