summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRanieri Althoff2019-06-22 21:31:09 +0200
committerRanieri Althoff2019-06-22 21:31:09 +0200
commitd4f8528c8302d4b1c2256d75df864b8feb618263 (patch)
treeb019f4c83c56db3113f233f0fc87f9bf2a258b16 /PKGBUILD
downloadaur-d4f8528c8302d4b1c2256d75df864b8feb618263.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f59e6720a58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
+
+_pkgname=mimalloc
+pkgname=${_pkgname}-git
+pkgver=r31.8a81a6c
+pkgrel=1
+pkgdesc='General-purpose allocator with excellent performance characteristics'
+arch=('x86_64')
+license=('MIT')
+url='https://github.com/microsoft/mimalloc'
+depends=('glibc')
+makedepends=('cmake')
+provides=('libmimalloc.so=1.0')
+_branch=master
+source=("${_pkgname}::git+https://github.com/microsoft/${_pkgname}.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}