summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2016-11-06 09:14:08 -0700
committerAinola2016-11-06 09:14:08 -0700
commit21edd5c7b93e071eec025ff45ec0f7b08c1aaa27 (patch)
tree857d32ab490315d890e1321c59e8c3b7046f439e /PKGBUILD
parent0a7ba5721f484bd6cf91513ece9fd9e25b8cd34c (diff)
downloadaur-21edd5c7b93e071eec025ff45ec0f7b08c1aaa27.tar.gz
not GPL3, but custom. Include licenses in pkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77f30a955333..24ad9b8556a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgname=minecraft-technic-launcher
pkgver=4.347
-pkgrel=2
+pkgrel=3
pkgdesc='Choose from thousands of community-made Minecraft modpacks available on the Technic Platform.'
arch=('any')
-license=('GPL3')
+license=('custom')
url='http://www.technicpack.net/'
depends=('java-runtime' 'xorg-xrandr' 'hicolor-icon-theme')
makedepends=('icoutils')
@@ -31,4 +31,8 @@ package(){
install -D -m644 "${srcdir}/icon_"?"_${size}x${size}x32.png" \
"${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/technic-launcher.png"
done
+
+ bsdtar xf TechnicLauncher.jar licenses
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname/licenses"
+ install -Dm644 licenses/* "$pkgdir/usr/share/doc/$pkgname/licenses"
}