summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorROllerozxa2021-12-25 21:21:10 +0100
committerROllerozxa2021-12-25 21:21:10 +0100
commitb47f23e1e466c3ac45945c6107504ab51903e10c (patch)
tree5d002e4f086e4df371d8b5fa165cff2ddc2e497d /PKGBUILD
downloadaur-b47f23e1e466c3ac45945c6107504ab51903e10c.tar.gz
Initializing new package from master Git repository.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52dbc8d199a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
+pkgname=minetest-builda-city
+_pkgname=buildacity
+_pkgauthor=Splizard
+pkgver=0.3.2
+_cdbrel=10209
+pkgrel=1
+pkgdesc="Your job is to build a city, so that you can supply it with electricity! Press I ingame for help."
+license=("AGPLv3")
+sha256sums=('1fd094996c4992c6e870478c888fbc46384c8bea0f89c17fd2a39065ee4361cf')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
+depends=("minetest-common")
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
+options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
+
+package() {
+ # the release zip has the files in the root of the archive
+ install -d "${pkgdir}/usr/share/minetest/games/${_pkgname}"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/${_pkgname}/"
+}