summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorROllerozxa2021-08-18 14:28:07 +0200
committerROllerozxa2021-08-18 14:28:07 +0200
commit02b2f28843882b03998d9b99d0053616cdd4bb9e (patch)
treee0d7d1bd190707ea60123a906924d92db68e8cfc /PKGBUILD
parent47173f753673fd2db36f6cd360fb15f3721ccbfb (diff)
downloadaur-02b2f28843882b03998d9b99d0053616cdd4bb9e.tar.gz
Rework PKGBUILD, update to latest.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 689402812df5..1b0820c15619 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Maintainer: ROllerozxa (temporaryemail4meh [gee mail])
+# Maintainer: ROllerozxa <temporaryemail4meh [gee mail]>
pkgname=minetest-nodecore
-pkgver=8128
+_pkgname=nodecore
+_pkgauthor=Warr1024
+pkgver=01472271
+_cdbrel=8919
pkgrel=1
pkgdesc="Original, immersive puzzle/adventure game with NO popup GUIs, minimal HUDs."
-arch=("any")
-url="https://content.minetest.net/packages/Warr1024/nodecore/"
license=("MIT")
+sha256sums=('7bdf5b06cdc9dad78ea324c38b7e43ac1c91f2fbd1413bd7c4c264b401cfdb5e')
+
+arch=("any")
+url="https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/"
depends=("minetest-common")
-source=("nodecore-$pkgver.zip::https://content.minetest.net/packages/Warr1024/nodecore/releases/${pkgver}/download/")
-sha256sums=('3efe5b0764b6f34d5c187ad3262481fe0d6987f95e12087cca949beed0ac45b0')
+source=("${_pkgname}-${pkgver}.zip::https://content.minetest.net/packages/${_pkgauthor}/${_pkgname}/releases/${_cdbrel}/download/")
options=(!strip)
+noextract=("${_pkgname}-${pkgver}.zip")
package() {
- for f in $(find . -type f); do
- install -Dm644 "$f" "$pkgdir/usr/share/minetest/games/nodecore/$f"
- done
+ # the nodecore release zip has the files in the root of the archive
+ install -d "${pkgdir}/usr/share/minetest/games/${_pkgname}"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share/minetest/games/${_pkgname}/"
}